通达信上下楼买卖指标公式

  • A+
所属分类:通达信公式
快:COUNT(CLOSE>REF(CLOSE,2),4)/4*100,COLOR00FF00;
慢:COUNT(CLOSE>REF(CLOSE,2),6)/6*100,COLORFFFFFF;
备钱:IF(快=0 AND 慢>20,20,0),COLORFF00FF;
低买:IF(快=0 AND BETWEEN(慢,1,20),50,0),COLORRED;
关注:IF(快=0 AND 慢=0,10,0),COLORFF8800;
JC:=(CROSS(快,1) AND 慢<=40) OR (CROSS(慢,20) AND 快<=50);
进场:IF(FILTER(JC,3),20,0),COLOR00FFFF,LINETHICK0;
STICKLINE(进场,0,100,0,-1),COLOR00FFFF;
QSXS:=快>=50 AND 快>=REF(快,1) AND 慢>=REF(慢,1);
上楼:IF(QSXS,1,0),COLOR0000FF,NODRAW;
风险:IF(快=100 AND 慢>=80,90,100),COLORFF00FF;
FXSJ:=BARSLAST(风险=90);
快跑:IF(FXSJ=1,1,0),COLORFFFF00,POINTDOT,NODRAW;
QSXX:=快<=REF(快,1) AND 慢<=REF(慢,1);
下楼:IF(FXSJ>=2 AND COUNT(QSXX,FXSJ)=FXSJ,1,0),COLOR00FFFF,NODRAW;
{以下设置副图显示方式}
A1:=IF(上楼,慢,快);
A2:=IF(下楼,慢,快);
DRAWBAND(快,RGB(255,0,0),A1,RGB(0,255,0));
DRAWBAND(快,RGB(255,255,255),A2,RGB(255,255,0));
DRAWTEXT(CROSS(备钱,1),30,\'备钱\'),COLORFF00FF;
DRAWTEXT(CROSS(低买,1),60,\'低买\'),COLORFFFFFF;
DRAWTEXT(CROSS(关注,1),20,\'关注\'),COLORFFFFFF;
DRAWTEXT(CROSS(LAST(关注,5,1),0.8),20,\'地下室\'),COLOR00FF00;
DRAWTEXT(FXSJ=1,100,\'跑\'),COLORFFFFFF;
DRAWICON(风险=90,110,13);

  • 我的微信
  • 这是我的微信扫一扫
  • weinxin
  • 我的微信公众号
  • 我的微信公众号扫一扫
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: